Wirehive phones unavailable

Minor incident Other / Third Party
2020-07-14 15:54 GMT · 1 hour, 31 minutes, 30 seconds

Updates

Resolved

This has been resolved, we had an issue with a supplier upstream from us. Apologies for any inconvenience.

July 14, 2020 · 17:26 GMT
Issue

Our main phone line is currently unavailable. Please contact us at support@wirehive.com for all issues. Apologies for the inconvenience while we work to resolve this.

July 14, 2020 · 15:57 GMT

← Back