Customer Portal Unavailable

Major incident Customer Portal
2020-07-14 16:09 GMT · 32 minutes, 52 seconds

Updates

Resolved

The issue has been resolved and the Customer Portal is working again

We are very sorry for the outage.

July 14, 2020 · 16:42 GMT
Issue

The customer portal is currently unavailable due to a network connectivity problem.

We are working to resolve the issue as soon as possible.

July 14, 2020 · 16:11 GMT

← Back