Customer Portal Errors

Minor incident Customer Portal
2020-07-24 09:52 GMT · 51 minutes, 34 seconds

Updates

Resolved

This issue is now resolved.

We are sorry for any inconvenience caused.

July 24, 2020 · 10:44 GMT
Issue

We are investigating an issue with errors in the Customer Portal

July 24, 2020 · 09:54 GMT

← Back