Issue with logging in to Customer Portal
Minor incident
Customer Portal
2020-08-18 11:36 GMT
·
1 hour, 10 minutes, 53 seconds
Updates
Resolved
August 18, 2020 · 12:47 GMT
This issue is now resolved.
We are very sorry for any inconvenience.
Investigating
August 18, 2020 · 11:37 GMT
We are currently investigating an error which is presenting users logging in to the Customer Portal
← Back