Phone system issue

Major incident Other / Third Party
2021-02-19 09:13 BST · 1 hour, 38 minutes, 26 seconds

Updates

Resolved

This issue has now been resolved

February 19, 2021 · 10:51 BST
Issue

We are experiencing intermittent service with our phones this morning, meaning calls to us might not reach us. If this affects you, please try again in a few minutes time or raise your query via email or our portal.

February 19, 2021 · 09:16 BST

← Back