Customer Portal - Issue viewing ticket replies

Minor incident Customer Portal
2021-02-22 22:06 BST · 20 minutes, 46 seconds

Updates

Resolved

We believe this issue has been resolved now. We apologise for any inconvenience caused.

February 22, 2021 · 22:26 BST
Investigating

We are aware of an issue viewing ticket replies in the Customer Portal and are working on a resolution.

February 22, 2021 · 22:08 BST

← Back