Regular phone numbers not working

Minor incident Other / Third Party
2020-02-01 01:17 BST · 7 hours, 55 minutes

Updates

Resolved

This is resolved as of approximately 05:00. The fault was down to a fibre breakage in Gammas network. Gamma are a major UK telephony provider and are involved in the number routing before it gets to us.

https://twitter.com/GammaSvcSupport/status/1223306207953330182?s=20

November 4, 2021 · 15:24 BST
Issue

We’ve been alerted to an issue with our phone system which is blocking calls from coming in to us. This looks to be a problem with our phone supplier, and we have asked them to investigate as a priority.

In the interim you can reach us on +44 3333 403030.

Apologies for trouble you may have had reaching us.

November 4, 2021 · 15:24 BST

← Back